Thursday, April 7, 2011

Bissell spot bot Model 7887 troubleshooting?

My SpotBot is not spraying. What should I try?

ANSWER: We are sorry you are experiencing difficulty with your machine not spraying properly. Please check the following:

- fill the solution tank with water or leave the solution/water mixture you currently have in the tank.
- plug the SpotBot in and turn the unit onto hose or manual setting
- hold/pump the trigger on the hose for 2 minutes.

Once the two minutes is complete, lift the solution tank up and down multiple times while pumping the trigger.

If the unit has not started spraying, cover the receiver area with your thumb and continue pumping the trigger. You should lift your finger to cover and uncover the black receiver area with your thumb (to create an air tight seal) multiple times.

Replace the solution tank into the machine as you continue to pump the trigger – the machine should have started spraying by now.

If you continue to experience difficulty with the machine not spraying, please contact BISSELL Canada Consumer Services at 1-800-263-2535, Monday - Friday 8 a.m. to 10 p.m., or Saturday 9 a.m. to 8 p.m., ET. A representative will assist you.


----------

This is direct link for the manual of the spotbot:---Click the link:--

http://dl.owneriq.net/4/49caac2d-6c34-4f9b-b347-049d6f8fb1f3.pdf

---------

The Repair manual for your spotbot:--------

Taking the SpotBot apart is a pretty easy task. All you really need is a Phillips head screw driver and a few minutes. A pair of pliers will be useful later on when moving hose clamps.


Start the disassembly by removing both the clean and dirty water tanks. Next, remove the clean water filter located in the plastic receptacle under the clean water tank as shown. This is easily done by hand or with a small set of pliers. If your filter happens to covered in calcium deposit, simply soak it in vinegar for a few minutes and rinse it off.

Removing the SpotBot clean water filter is easy to do by hand or with a small set of pliers.

Next you need to remove the screw holding the clean water tray to the rest of the SpotBot body.

Remove the screw shown here to lift the clean water tray from the unit

Now, remove the two screws holding this side of the upper body to the lower body.

Remove the two screws shown here to detach the clean water side of the upper body from the lower body

Turn the SpotBot around so that you are looking at the dirty water end. You may be tempted to remove the two screws located on the dirty water outlet connector. You can do so if you would like to remove the entire hose assembly. Instead, remove the two screws in the picture which attach this side of the upper body to the lower body.

Remove these two screws to separate the upper body from the lower body on the dirty water side.

Gently lift the upper body of the SpotBot from the lower body. You should rest the upper body on something so that you do not strain any hoses or wires. I used the dirty water tank turned on its side to support the upper body.


Looking inside, you will see a mess of wires and hoses. We are going to focus on the clean water side, as that is where the pump resides. You can feel free to test the pump if you wish. If your SpotBot is not spraying water, I would say that it is very likely the pump has given out, but you can remove the pump and check for suction if you feel like it. Otherwise continue along.

You first want to remove the two leads that power the pump. This pump runs on 120V, so you want to make sure that you have unplugged the SpotBot before touching these wires. Note the orientation of the leads: red facing up towards you, white facing away from you.

ote the orientation of the power leads on the SpotBot pump.  Red is facing up towards you, white away from you.

Remove the two black screws that hold the water pump retention bracket and pull the pump away from its mount as seen in the pictures below.

Remove the two black screws to remove the pump mounting bracket from the upper body.Here is the pump, disconnected from the upper body portion of the SpotBot.

Looking at the pump, you will notice that it is connected to two hoses, one for the inlet and one for the outlet. The inlet hose is not pressurized, so it does not require a hose clamp. The outlet hose however is subject to pressure, so it utilizes a relatively large clamp. Disconnect both ends of the pump, using any combination of twisting and pulling. Just be sure not to stress any of the other hoses. When you are done, you should have this:

This is the Invensys pump used in the SpotBot. OEM Part number 203-6659 - Invensys CL1 120v 60Hz 14w continuous.


--------------------------


Before you reconnect your pump to your SpotBot, I have one piece of advice: Shrink any hoses you have disconnected from their fittings back to proper size. This includes the two hoses you disconnected from the pump as well as any hose you might have removed for testing or dislodged by accident. I found that when I reconnected everything, I had leaks wherever I removed a hose, despite the hose clamps. I found that heating the tip of each clear polyurethane hose with my heat gun would return them to their original diameter, allowing me to refit them as if they were new. I used a heat gun on the low setting, though I bet you could probably use a hair dryer. Evenly heat the hose ends until you see the tubing retake its original shape, let them cool for a few minutes, then reconnect the fittings. You will be glad you took the extra time to do this, trust me.

Reconnect the pump to the water inlet hose as shown in the picture, paying close attention to the flow indicator printed on the pump. This shows you which way the water should flow through the pump, which is with the small fitting at the top and the large fitting at the bottom.

Ensure that you attach the SpotBot pump so that the water flows correctly.

Before attaching the “T” connector back to the pump, slide on the bracket that holds the pump to the upper body. If you forget to do this now, you will have to pull the hoses back off to properly reattach the pump.

Reattach the bracket to the pump before attaching that last hose or you will have to do it all again!

Attach the bottom hose, then mount the pump back into the upper body of the SpotBot using the two black screws you removed. Reattach the power leads in the orientation shown earlier.

Now before you test the unit, you should ensure that all hoses and wires are attached in their proper locations. I did not do this and found that the manual attachment would not spray any water. I poked around for a minute and noticed that the sensor wires for the manual attachment were disconnected from the main board. At some point, I must have moved the top of the SpotBot body too far from the base, disconnecting the wire. You can see the red and yellow wire pair in my hand, though the picture is a touch blurry.

This pair of red and yellow wires is the flow sensor for the manual attachment. Ensure that this is still connected to the main board after you have completed your repairs.

The wires connect to the main board just to the right of where I am pointing my finger. I had to reattach them using a pair of long nosed pliers.

Manual hose sensor connection on the SpotBot motherboard.

To test the unit, fill the clean water tank half way and place it on the top half of the body. You will likely need to hold it steady during testing. All you really need to do is ensure that the tank is positioned so that water can flow to the pump. Plug in the unit, be careful not to touch any electrical parts, and turn it to manual mode. Depress the manual attachment pump trigger and hopefully you will see something like this:

Houston, we have liftoff - The repair was a success!

Success!

Now that the pump is working, check for leaks at all of the connections. If you heated the hoses before reconnecting, you should be in the clear. If not, shame on you.

Now it’s time to put everything back together. As you reassemble the unit, just make sure there is no pinching at the point where the hose for the manual attachment leaves the body of the unit. The only way this would have shifted is if you removed the dirty water outlet I briefly mentioned earlier. Check the spot in the picture to ensure proper water flow.

Ensure the water supply hose is not crimped

Finally, before closing the unit, make sure the water hose shown below is routed to the outside edge of the screw receptacle. This should ensure a smooth reassembly without any sort of hose compression or undue stress on the lines.

Route the water supply hose around the plastic knob to ensure a good fit.

There you have it. Once you reassemble the rest of the unit, you can congratulate yourself on fixing your SpotBot for $20 instead of buying a new one for over $100.


One final tip: Care and feeding of your SpotBot includes emptying and rinsing the dirty water tank after each use, as well as flushing out the waste return hose.