Saturday, October 6, 2012

2007 ford expedition engine cranks but wont start

Engine cranks fine but will not start



A common problem,noticed on many other vehicles too.

On this cases first see if the check engine light is coming on and remaining steady or blinking.

In any cases,getting the vehicle scanned helps.
At autozone service centers its free to get vehicle scanned.

But if no error code stored or no codes retrieved in diagnostics then for troubleshooting,you have to test and inspect few common parts manually.


When you turn the key to the start position, What does the red theft light in the dash do?



Inspect this light properly,Does it blink fast, stay on or go out?


If it blinks faster than normal you may have an anti theft problem but, If you hear a clicking noise coming from the engine compartment, this may be the sign of a weak battery with not enough cold cranking amps to turn over the starter or a faulty starter motor.

In this case,try jump starting the vehicle and see,if it starts fine by jump start,then its isue with weak battery or loose battery to start connections.
Get the vehicle checked with replacement battery.


Yes, the vehicle could have 12 volts which is what is needed to run all lights and accessories but the cranking amps are what is needed to turn over the starter as it requires a high amperage.

But if battery and other voltages,including starter checked ok,then the next thing to be checked is fuel system.

Try starting with starter fluid on throttle body and see if vehicle is running with starter fluid or not.
If yes then issue is with faulty or weak fuel pump or the fuel filter is dirty and needs to be cleaned or replaced.

Also before replacing fuel pump,get the inertia switch checked.


You have to check power coming into the inertia switch and power going out, if that's good then so far its looking like a new fuel pump is in order

There are two wires coming from inertia switch.The inertia switch wires should give the same voltage of what the car battery voltage is.
The battery voltage should be 12 volts.So the wires on inertia switch should give approx 12 volts.

The inertia switch for your vehicle is located behind the removable trim panel in the left side rear of the vehicle.

 If the above troubleshooting details do not help.Then the problem is related to faulty sensors.Both camshaft sensor and crankshaft sensor.First  replace the camshaft position sensor. If that doesn't fix it; replace the crankshaft position sensor.

But if any of these sensors are faulty,then in vehicle scan diagnosis,you should get error codes,pointing out these sensors to be faulty.


These details will help.
Thanks.


Users Who Viewed This Problem Also Viewed:

For All types of Car models and brands help 
Go to Newly Launched

FREE Car repair guide? 
http://technoanswers.blogspot.in/2012/03/car-repair-guide.html 

& 
Complete Car repair Help FREE? 
http://repairhelpcenter.blogspot.in/2012/03/complete-car-repair-help.html

Ford Expedition and Lincoln Navigator Repair Guide?

http://technoanswers.blogspot.in/2012/03/ford-expedition-and-lincoln-navigator.html


1997 Oldsmobile Cutlass Ciera: The Engine cranks but not start?

http://schematicsdiagram.blogspot.in/2012/04/1997-oldsmobile-cutlass-ciera-engine.html










max